package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-9][0-9]{0,2}(?:,?[0-9]{3}){0,3}(?:\.[0-9]{1,2})?$`)
var str = `999.99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}