package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))`)
var str = `R1102
R1170
R1103
R89052
R89110
R89129
R89130
R89145
R891425
Q1103
RQ1103
RR890529
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}