import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))";
final String string = "R1102\n"
+ "R1170\n"
+ "R1103\n"
+ "R89052\n"
+ "R89110\n"
+ "R89129\n"
+ "R89130\n"
+ "R89145\n"
+ "R891425\n"
+ "Q1103\n"
+ "RQ1103\n"
+ "RR890529\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}