const regex = /(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))', 'g')
const str = `R1102
R1170
R1103
R89052
R89110
R89129
R89130
R89145
R891425
Q1103
RQ1103
RR890529
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}