# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))"
test_str = ("R1102\n"
"R1170\n"
"R1103\n"
"R89052\n"
"R89110\n"
"R89129\n"
"R89130\n"
"R89145\n"
"R891425\n"
"Q1103\n"
"RQ1103\n"
"RR890529\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.