// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))").unwrap();
let string = "R1102
R1170
R1103
R89052
R89110
R89129
R89130
R89145
R891425
Q1103
RQ1103
RR890529
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}