import Foundation
let pattern = #"(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
R1102
R1170
R1103
R89052
R89110
R89129
R89130
R89145
R891425
Q1103
RQ1103
RR890529
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)