$re = '/^\w++(?<!_min)\.(jpg|gif)/m';
$str = 'desc_125f.jpg -> matched,
desc#_56.jpg -> not matched (contains #),
bla_bla.gif -> matched,
bla_bla.png -> not matched (extension is png),
desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),
desc_min256.gif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);