#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}"
Local $sString = "5c251366-f548-4aaf-a1cc-3dc3372d1302" & @CRLF & _
"c54579ac-1e3c-41ab-a020-1eaf2de425ab" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")