// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+(?:\s*x\s*[0-9]+)+\s*").unwrap();
let string = "16 x 13 x 12 inch box
1x2x3 pipe
123x 23 x334 asd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}