using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z](?:[a-z]+|[A-Z]+(?![a-z]))?|\d+";
string input = @"Hello123AIIsCoolAndHTML5IsAMarkupLanguage";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}