#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z ]+$"
Local $sString = "Bruce Schneier" & @CRLF & _
"Schneier, Bruce" & @CRLF & _
"Schneier, Bruce Wayne" & @CRLF & _
"O'Malley, John F." & @CRLF & _
"John O'Malley-Smith" & @CRLF & _
"Cher"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")