re = /((?:(?:",")|(?:[^",]*))*?)(?:,|$)/m
str = '3",",3,4,f","3,",",",",","","3'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result