package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^.]*).*`)
var str = `test_2.3005.i-rewq873.example.local`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}