use strict;
my $str = 'test_2.3005.i-rewq873.example.local';
my $regex = qr/^([^.]*).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";