package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(\s|.)*\bCHARACTER SET\b((\s|.)*\bCOLLATE\b)?`)
var str = `add
CHARACTER SET
COLLATE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}