// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[Ii][Nn][Vv][Oo][Ii][Cc][Ee](?:[[:punct:]]*\s*)*(.*)$").unwrap();
let string = "Part Lot.: SIM
Telex Release.: SIM
Sea Waybill.: SIM
L/C(Cart. Crédito).: SIM
DU.: SIM - TEST Fer 15:11
PIP.: SIM - pip
MOZ.: SIM
PIV.: SIM - TESTE 123
Incoterms.: SIM
SKU Espelho.: SIM
Inspeção.: SIM
Etiqueta.: SIM
Invoice.: .: teste Fer 15:11
Packing list.: teste Fer 15:11
teste Lisa 15:11
Quantidade CNTR.: SIM - 000123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}