package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i:ab)II`)
var str = `abii
abII
Abii
AbII
ABii
ABII`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}