# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=(?:\d\d\d)+(?!\d))/./gm;t' <<< "158841054854
2022
602300000000000000000000
1298615
"