import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<[ \\t]*begin[ \\t]>[^<]*([\\s\\S]*?)^<[ \\t]*end[ \\t]*>";
final String string = "< begin >\n"
+ " < datapt > 1 < datapt >\n"
+ " < xunit > mass < xunit >\n"
+ " < xval > 150.000097 < xval >\n"
+ " < yunit > abs < yunit >\n"
+ " < yval > 0.000000 < yval >\n"
+ "< end >\n\n"
+ "< begin >\n"
+ " < datapt > 2 < datapt >\n"
+ " < xunit > mass < xunit >\n"
+ " < xval > 150.000245 < xval >\n"
+ " < yunit > abs < yunit >\n"
+ " < yval > 0.000000 < yval >\n"
+ "< end >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}