$re = '/(^[^\[]+|\][^\]]+$)|\s+/m';
$str = 'a b c [a b c] d e f';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;