const regex = /^(?:|(https?:\/\/)?(|www)[.]?((t|telegram)\.me)\/)[a-zA-Z0-9_]{5,32}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:|(https?:\\\/\\\/)?(|www)[.]?((t|telegram)\\.me)\\\/)[a-zA-Z0-9_]{5,32}$', 'gm')
const str = `https://telegram.me/opensid
http://telegram.me/opensid
www.telegram.me/opensid
telegram.me/opensid
www.t.me/opensid
t.me/opensid
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}