$re = '~(?:\G(?!\A)|{)
[^{}]*?\K
ostrich~x';
$str = 'cat {mouse ostrich dog ostrich} fish {ostrich} ostrich';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);