#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^_.*(*SKIP)(*F)|\[\[|]]"
Local $sString = "## [[zoom]] _[v]_" & @CRLF & _
"" & @CRLF & _
">[[move]] | [[very]] | [[quickly]]" & @CRLF & _
"" & @CRLF & _
"__Synonyms__: [[buzz]] | [[dart]] | [[dash]] | [[dive]] | [[flash]] | [[fly]] | [[hum]] | [[hurtle]] | outstrip | [[rip]] | [[rocket]] | [[rush]] | [[shoot]] | [[shoot]] up | [[skyrocket]] | [[speed]] | [[streak]] | [[surge]] | [[tear]] | [[whirl]] | [[whiz]] | [[zip]]" & @CRLF & _
"" & @CRLF & _
"__Concepts__: [[ACTIONS - MOTION#move oneself quickly (150)\|move oneself quickly]] " & @CRLF & _
"" & @CRLF & _
"__Antonyms__: decelerate, [[slow]]" & @CRLF & _
"" & @CRLF & _
"## [[zip]] _[n]_" & @CRLF & _
"" & @CRLF & _
">[[enthusiasm]], [[energy]]" & @CRLF & _
"" & @CRLF & _
"__Synonyms__: brio | [[drive]] | [[get]]-upand-[[go]] | [[go]] | [[gusto]] | [[life]] | liveliness | [[oomph]] | [[pep]] | [[pizzazz]] | [[punch]] | [[sparkle]] | [[spirit]] | [[verve]] | [[vigor]] | vim | [[vitality]] | [[zest]] | [[zing]]" & @CRLF & _
"" & @CRLF & _
"__Concepts__: [[LIFE FORMS - GENERAL CHARACTERISTICS#personality (411)\|personality]], [[STATES - ABSTRACT#behavior (633)\|behavior]] " & @CRLF & _
"" & @CRLF & _
"__Antonyms__: [[apathy]], enervation, [[idleness]], [[laziness]], [[lethargy]]" & @CRLF & _
" " & @CRLF & _
"## [[zip]] _[v]_" & @CRLF & _
"" & @CRLF & _
">[[move]] | [[about]] | [[quickly]]" & @CRLF & _
"" & @CRLF & _
"__Synonyms__: [[bustle]] | [[dash]] | [[flash]] | [[fly]] | [[hasten]] | [[hurry]] | [[run]] | [[rush]] | [[shoot]] | [[speed]] | [[tear]] | waltz | [[whisk]] | [[whiz]] | [[zoom]]" & @CRLF & _
"" & @CRLF & _
"__Concepts__: [[ACTIONS - MOTION#move oneself quickly (150)\|move oneself quickly]] " & @CRLF & _
"" & @CRLF & _
"__Antonyms__: decelerate, [[slow]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")