re = /Instruction:\s*(.*)(?=Input:)/m
str = 'Instruction: Create a new directory for your project.
Input: None'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end