re = /[A-Z]{1}(\s)/m
str = 'E.g Mark S Twain==> S to be replaced as string.empty and result to be “Mark Twain”
J Mark Tailor ==> Again J to be replaced as string.empty and result to be “Mark Tailor”'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end