#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(pp\.\s+\d+(?:-\d+)?\)|\b\d+(?:-\d+)?(?=(?:\s*,\s*\d+(?:-\d+)?)*\.)"
Local $sString = "- Mitchell, J.A. (2017). Citation: Why is it so important. Mendeley Journal, 67(2), (pp. 81-95). " & @CRLF & _
"" & @CRLF & _
"- Denhart, H. (2008). Deconstructing barriers: Perceptions of students labeled with learning disabilities in higher education. Journal of Learning Disabilities, 40,41, 483-497." & @CRLF & _
"" & @CRLF & _
"(pp. 81). " & @CRLF & _
"12-12" & @CRLF & _
"http://test.com/12-23" & @CRLF & _
"" & @CRLF & _
"Usually the page numbers follow a commas and then there is a dot (like this: , 1-2. ) How can I change the code according to this? Same goes for when there is only one page listed , number. and the ` (pp. 12)` format."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")