#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=suppl/)(.*(?:pdf|doc|xml))"
Local $sString = "0040-1719933/suppl/sup_ss-2022-f0205-op_10-1055_s-0040-1719933.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")