Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\+?(\b1)?[\ .\/-]?((?(2)|(\b))|(\())\d{3}(?(?<=\(\d{3})\)|)[\ .\/-]?)?(?(1)|\b)\d{3}[\ .\/-]?\d{4}[\ ]?([xX][\ ]?\d{1,5})?\b
/
gm
Input 1
1
New
+ (513)899-1888 5138991888 8991888 1 5138991888 +5138991888 (513)8991888 1(513)8991888 (5138991888 +1 513-899-1888 1/513-899-1888 1(513)899-1888 X 8888 +1 513 899-1888 x 11111