const regex = new RegExp('\\[(?>[^][]+|(?<c>)\\[|(?<-c>)])+]', 'gm')
const str = `[A] + -[B123]=0
[Test[0]]=0
[value] in the [text[42]] and [1[2[3]]]!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}