#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^CTC\sN\+(?:123\d{9}|(?!123)\d{10,12})\/?(EN|FR)?$"
Local $sString = "CTC N+6534567890/FR" & @CRLF & _
"CTC N+123456789012/FR" & @CRLF & _
"CTC N+1234567890120/FR" & @CRLF & _
"CTC N+1234567890/FR" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")