use strict;
my $str = 'CTC N+6534567890/FR
CTC N+123456789012/FR
CTC N+1234567890120/FR
CTC N+1234567890/FR
';
my $regex = qr/^CTC\sN\+(?:123\d{9}|(?!123)\d{10,12})\/?(EN|FR)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}