import re
regex = re.compile(r"^CTC\sN\+(?:123\d{9}|(?!123)\d{10,12})\/?(EN|FR)?$", flags=re.MULTILINE)
test_str = ("CTC N+6534567890/FR\n"
"CTC N+123456789012/FR\n"
"CTC N+1234567890120/FR\n"
"CTC N+1234567890/FR\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")