use strict;
my $str = 'Meet God\\\'s General Kathryn Kuhlman. <br>
<img class="lazy_responsive" title="¬¦@#~Kathryn Kuhlman - iUseFaith.com" src="https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg" alt="¬¦@#~Kathryn Kuhlman - iUseFaith.com" width="1600" height="517" />
<br>
Follow <a href="https://www.iusefaith.com/en-354" title="¬¦@#~Kathryn Kuhlman">¬¦@#~Kathryn Kuhlman</a>
<br>
Max KANTCHEDE
<a href = "blah blah blah ¬¦@#~Kathryn Kuhlman"/>¬¦@#~Kathryn Kuhlman</a>';
my $regex = qr/(?<!¬¦@#~)(Kathryn Kuhlman|Max KANTCHEDE)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}