import Foundation
let pattern = ##"(?<!¬¦@#~)(Kathryn Kuhlman|Max KANTCHEDE)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Meet God\'s General Kathryn Kuhlman. <br>
<img class="lazy_responsive" title="¬¦@#~Kathryn Kuhlman - iUseFaith.com" src="https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg" alt="¬¦@#~Kathryn Kuhlman - iUseFaith.com" width="1600" height="517" />
<br>
Follow <a href="https://www.iusefaith.com/en-354" title="¬¦@#~Kathryn Kuhlman">¬¦@#~Kathryn Kuhlman</a>
<br>
Max KANTCHEDE
<a href = "blah blah blah ¬¦@#~Kathryn Kuhlman"/>¬¦@#~Kathryn Kuhlman</a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)