re = /(?i)=.*?\Krobot/mi
str = 'For example:
preview_download_robot=View your beautiful Robot!
I would like to replace the word "Robot" with "Android", but only after the = symbol. It should apply to any variation of the word "Robot" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure. '
subst = 'Android'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result