const regex = /(?-i)^[\t ]*((?:[!(]|\w+\(|(?:(?:const|let|var)[\t ]+)?[\w$]+[\t ]*[:=][\t ]*(?:{\w+[\t ]*:[\t ]*)?)?)((?:\([^\r\n)]*\)|\w)[\t ]*=>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-i)^[\\t ]*((?:[!(]|\\w+\\(|(?:(?:const|let|var)[\\t ]+)?[\\w$]+[\\t ]*[:=][\\t ]*(?:{\\w+[\\t ]*:[\\t ]*)?)?)((?:\\([^\\r\\n)]*\\)|\\w)[\\t ]*=>)', 'gm')
const str = `!function(){}(); // test1
!function test2(){}(); // test2
(function(){})(); // test3
(function test4(){})(); // test4
test5 = function(){} // test5
test6 = function _test6(){} // test6
let test7 = function(){} // test7
let test8 = function _test8(){} // test8
var test9 = function(){} // test8
var test10 = function _test10(){} // test10
const test11 = function(){} // test11
const test12 = function _test12(){} // test12
myfunc(function(){}) // test13
myfunc(function test14(){}) // test14
let myobj15 = {test15 : function(){}} // test15
let myobj16 = {test16 : function _test16(){}} // test16
var myobj17 = {test17 : function(){}} // test17
var myobj18 = {test18 : function _test18(){}} // test18
const myobj19 = {test19 : function(){}} // test19
const myobj20 = {test20 : function _test20(){}} // test20
!function(a){}(); // test21
!function test22(b){}(); // test22
(function(c){})(); // test23
(function test24(d){})(); // test24
test25 = function(e){} // test25
test26 = function _test26(f){} // test26
let test27 = function(g){} // test27
let test28 = function _test28(h){} // test28
var test29 = function(i){} // test29
var test30 = function _test30(j){} // test30
const test31 = function(k){} // test31
const test32 = function _test32(l){} // test32
myfunc(function(m){}) // test33
myfunc(function test34(n){}) // test34
let myobj35 = {
test35 : function(o){} // test35
}
let myobj36 = {
test36 : function _test36(p){} // test36
}
var myobj37 = {
test37 : function(q){} // test37
}
var myobj38 = {
test38 : function _test38(r){} // test38
}
test39 = () => {} // test39
test40 = v => {} // test40
test41 = (w) => {} // test41
test42 = (x,y) => {} // test42
let test43 = v => {} // test43
var myobj44 = {test44 : (w) => {}} // test44
const myobj45 = {
test45 : (x,y) => {} // test45
}
myfunc(() => {}) // test46
myfunc(v => {}) // test47
function test48(){} // test48
function test49(s){} // test49
function test50(t,u){} // test50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}