$re = '/^(?:(?:[,"\n]|"[^"]*"),){2}\K".*?",?(,".*?",)/m';
$str = '"Test","test","test1234","",""
"Test","test","test1234","url_test.com/test",""
"Test","test","test1234","","testing"
"Test","test","test12"34","",""
"Test","test","te\\"st1234","",""
"Test","test","test1"2,34","",""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);