re = /^(?:(?:[,"\n]|"[^"]*"),){2}\K".*?",?(,".*?",)/m
str = '"Test","test","test1234","",""
"Test","test","test1234","url_test.com/test",""
"Test","test","test1234","","testing"
"Test","test","test12"34","",""
"Test","test","te\\"st1234","",""
"Test","test","test1"2,34","",""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end