#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[,"\n]|"[^"]*"),){2}\K".*?"(?=(?:,(?:[,"\n]|"[^"]*")){2}$)"
Local $sString = ""Test","test","test1234","",""" & @CRLF & _
""Test","test","test1234","url_test.com/test",""" & @CRLF & _
""Test","test","test1234","","testing"" & @CRLF & _
""Test","test","test12"34","",""" & @CRLF & _
""Test","test","te\"st1234","",""" & @CRLF & _
""Test","test","test1"2,34","","""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")