using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[,""\n]|""[^""]*""),){2}\K"".*?""(?=(?:,(?:[,""\n]|""[^""]*"")){2}$)";
string input = @"""Test"",""test"",""test1234"","",""
""Test"",""test"",""test1234"",""url_test.com/test"",""
""Test"",""test"",""test1234"","",""testing""
""Test"",""test"",""test12""34"","",""
""Test"",""test"",""te\""st1234"","",""
""Test"",""test"",""test1""2,34"","",""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}