// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[^A-Za-z 0-9 \.,\?""!@#\$%\^&\*\(\)-_=\+;:<>\/\\\|\}\{\[\]`~|\xE0-\xE6|\xC0-\xC6|\xE8-\xEB|\xC8-\xCB|\xEC-\xEF|\xCC-\xCF|\xF2-\xF6|\xD2-\xD6|\xF9-\xFC|\xD9-\xDC|\xE7|\xC7|\xF1|\xD1]*"#).unwrap();
let string = "aÇÃO
ANÃO
único
Único
íma
irmão";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}