#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?!\/*strong\W|\/*h1\W|\/*input\W|\/*b\W).*?>"
Local $sString = "<form action="#" method="post">" & @CRLF & _
" <div>" & @CRLF & _
" <label for="name">Text Input:</label>" & @CRLF & _
" <input type="text" name="name" id="name" value="" tabindex="1" />" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div>" & @CRLF & _
" <h4>Radio Button Choice</h4>" & @CRLF & _
"" & @CRLF & _
" <label for="radio-choice-1">Choice 1</label>" & @CRLF & _
" <input type="radio" name="radio-choice-1" id="radio-choice-1" tabindex="2" value="choice-1" />" & @CRLF & _
"" & @CRLF & _
" <label for="radio-choice-2">Choice 2</label>" & @CRLF & _
" <input type="radio" name="radio-choice-2" id="radio-choice-2" tabindex="3" value="choice-2" />" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div>" & @CRLF & _
" <label for="select-choice">Select Dropdown Choice:</label>" & @CRLF & _
" <select name="select-choice" id="select-choice">" & @CRLF & _
" <option value="Choice 1">Choice 1</option>" & @CRLF & _
" <option value="Choice 2">Choice 2</option>" & @CRLF & _
" <option value="Choice 3">Choice 3</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div>" & @CRLF & _
" <label for="textarea">Textarea:</label>" & @CRLF & _
" <textarea cols="40" rows="8" name="textarea" id="textarea"></textarea>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div>" & @CRLF & _
" <label for="checkbox">Checkbox:</label>" & @CRLF & _
" <input type="checkbox" name="checkbox" id="checkbox" />" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div>" & @CRLF & _
" <input type="submit" value="Submit" />" & @CRLF & _
" </div>" & @CRLF & _
"</form>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")