#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bRecipient:\s*(\S+@\S+)"
Local $sString = "Recipient:" & @CRLF & _
"nolo.lamb@golab.com \--- mail_boundary --- ATTENTION: This email came from an" & @CRLF & _
"external source." & @CRLF & _
" " & @CRLF & _
"Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO" & @CRLF & _
"AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>" & @CRLF & _
"Recipient: Nichole.wen@golab.com \--- mail_boundary ---"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")