package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bRecipient:\s*(\S+@\S+)`)
var str = `Recipient:
nolo.lamb@golab.com \--- mail_boundary --- ATTENTION: This email came from an
external source.
Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO
AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>
Recipient: Nichole.wen@golab.com \--- mail_boundary ---`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}