$re = '/\[{2}[^[\]]+\]{2}/m';
$str = 'some text [[someword]] some [[some other word]]other text ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);