# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\d{2}\.\d{2}\.\d{2}\s\d{2}\:\d{2}\:\d{2}\:\d{1,3}\sMET\].+The Application\s([a-zA-Z0-9]*)\sis starting\.[\s\S]*\[\d{2}\.\d{2}\.\d{2}\s\d{2}\:\d{2}\:\d{2}\:\d{1,3}\sMET\].+The Application started:\s\1"
test_str = ("[10.12.19 15:29:10:408 MET] 0000006a ApplicationMg A WSVR0200I: The Application query is starting.\n"
"[10.12.19 15:29:11:102 MET] 0000006a CompositionUn A WSVR0191I: Composition unit AB started\n"
"[10.12.19 15:29:11:222 MET] 0000006a CompositionUn A WSVR0191I: Composition unit CD started\n"
"[10.12.19 15:29:11:412 MET] 0000006a ApplicationMg A WSVR0200I: The Application tracer is starting.\n"
"[10.12.19 15:29:12:108 MET] 0000006a CompositionUn A WSVR0191I: Composition unit DE started.\n"
"[10.12.19 15:29:12:541 MET] 0000006a ApplicationMg A WSVR0200I: The Application started: query\n"
"[10.12.19 15:29:13:417 MET] 0000006a ApplicationMg A WSVR0200I: The Application started: tracer\n\n"
"[10.12.19 15:30:12:145 MET] 0000006a ApplicationMg A WSVR0200I: The Application test is starting.\n"
"[10.12.19 15:30:13:408 MET] 0000006a CompositionUn A WSVR0191I: Composition unit XY started.\n"
"[10.12.19 15:30:14:678 MET] 0000006a ApplicationMg A WSVR0200I: The Application started: test")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.