package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bx\S+z\b`)
var str = `xaz xazx xaxsza zsxdaszdx zasxz xaaz xaaaz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}