$re = '/(?<=[.?!]|^)(?:СЛОВО2()|СЛОВО()(?:\1())?|[^.?!])++\2(?!\3)/';
$str = 'Раз СЛОВО2 два СЛОВО.
Раз СЛОВО два СЛОВО2 три СЛОВО.
Раз СЛОВО два СЛОВО2.';
$subst = " ЗАМЕНА";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;