$re = '/(?<=-)\s*\d+.*/';
$str = 'On Gas - Limited - 115 - 116 Hunua Road';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);